Tagged: , ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • Customer Inquiry
    Member
    Post count: 197

    When my computing environment starts up (eg: after long power outage) all my devices come up at once. This causes the PBX node to be ready before the rest of the network, causing false problem detection for HAAst (and a license check problem).

    What is the best way to delay HAAst start (I’m running Red Hat 8) on system boot? I do NOT want to introduce a delay for every service start/restart

    Telium Support Group
    Member
    Post count: 258

    Since Red Hat 8 uses SystemD, the best way to delay HAAst start is with a service timer. Create the file haast.timer in the /etc/systemd/system directory with the following contents

    [Unit]
    Description=Delay HAAst start by 1 minute on bootup
    
    [Timer]
    OnBootSec=1min
    Unit=haast.service
    
    [Install]
    WantedBy=basic.target

    Then, enable the HAAst timer and disable the service:

    systemctl enable haast.timer
    systemctl disable haast.service

    And finally, in your haast.service file change the WantedBy line to read:

    [Install]
    WantedBy=haast.timer

    Next inform systemd of your changes:

    systemctl daemon-reload

    And your HAAst start will delay by 1 minute on bootup. You can adjust the delay as you need.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.