Home Forums HAast (High Availability for Asterisk) Installation & Upgrade Asterisk + FreePBX 10 not shutting down on demotion

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • Customer Inquiry
    Member
    Post count: 197

    I have FreePBX(TM) 10 installed on Red Hat (TM) 7. When the peer demotes I find that Asterisk(TM) is not stopping (stays running), and systemctl reports that the Asterisk service is dead. How do I fix this?

    Telium Support Group
    Member
    Post count: 258

    Seeing a status from systemctl that the Asterisk service is dead is not necessarily a problem. Systemd reports on services it starts & stops; and since HAAst does not start/stop Asterisk through systemd it’s normal to see a message like this. More specifically, the Linux distro + FreePBX distro + Asterisk combination will report different status results for individual services. So seeing a systemctl status report that something is dead/not started/started may be misleading.

    If you are sure that the Asterisk service should be stopped (based on the status of the peer), then we recommend paring back your environment to a single simple PBX (strip down the layers). This will let you trace the problem down to a single cause:

    1. Disable HAAst layer
      1. Power down the remote PBX (peer). Now we’re working with only the local peer (less variables to check)
      2. Disable the haast service and reboot the local peer
      3. After reboot check if Asterisk is running
      4. Check the haast log to ensure it did not start
      5. If HAAst and Asterisk are stopped lets try operating on FreePBX directly. (Proceed to step 2)
      6. If you got here that means you forgot to disable automatic start of Asterisk/FreePBX as outlined in the installation guide.
    2. Test FreePBX layer directly
      1. Start FreePBX with ‘fwconsole start’.
      2. Were there any warnings?
      3. Is Asterisk running normally?
      4. Now stop FreePBX with ‘fwconsole stop’
      5. Were there any warnings?
      6. Is Asterisk stopped?
      7. If you see FreePBX errors correct them and reboot the PBX and return to step 2A
      8. if you don’t see any errors then HAAst is having trouble controlling FreePBX. Check the ‘distribution’ setting in the haast.conf file
      9. If haast.conf settings are correct test the Asterisk layer directly
    3. Test Asterisk layer directly
      1. Ensure the FreePBX service / start command is disabled as per the HAAst installation guide
      2. Reboot the PBX
      3. If asterisk is started that means you forgot to disable automatic start of Asterisk/FreePBX as outlined in the installation guide.
      4. Start and stop the asterisk service using ‘service’ or ‘systemctl’ commands appropriate for your distribution. Did this show an error?
      5. If you got to this point contact Telium support for assistance through SSH.

    Most users find a FreePBX internal problem (eg: ) and upon resolution all works fine again. If you are new to FreePBX you will discover (google) that these types of problems are with FreePBX are well documented. FreePBX may fail to start, fail to stop, etc. which also blocks the Asterisk process from starting/stopping. There is nothing Telium/HAAst can do about this (i.e. FreePBX issue). But if you encounter symptoms as described in the original question then try this procedure to help diagnose the problem.

    Telium can offer some suggestions on diagnosing such FreePBX issues but tracking down the cause of FreePBX error messages can be time consuming. Please note that other distributions such as xCALLY Motion do not encounter this type of problem.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.